Home‎ > ‎Large Systems Collection‎ > ‎PDP-8/S #1‎ > ‎

PDP-8/S #1 Restoration

12-FEB-2011

It was just like a scene from the American Pickers TV show.Dan (Mike Wolf) and Mike (Frank Fritz) picked up the Ryder rental Metro Van at 7:00 AM and headed off on a 250 mile drive to Pennsylvania to pick up a donated DEC PDP-8/S, TU56 DECtape and TC11 controller, and a PDP-11/34 with a RK611 disk controller. The trip out was uneventful other than running into a massive traffic jam at the George Washington Bridge. Dan decided to take a detour through the middle of Manhattan to the Lincoln Tunnel instead of waiting in line for about two hours to get the the GW bridge. We had to turn the voice on the GPS off because it was going wild when the satellite signals got blocked by the skyscrapers. We eventually got to Robin's house and picked up the equipment and lots of spare parts. The trip home was easy. We unloaded the equipment at the warehouse, dropped off the van, and headed home.

13-FEB-2011

We inventoried the boards in the PDP-8/S, TU56 and controller, and in the PDP-11/34. We took lots of pictures and dug through the boxes to see what goodies were there. It looks like we have all of the documentation for the PDP-8/S and the PDP-11/34. There were four dozen DECtapes, and about 100 paper tapes of software and diagnostics for the PDP-8/S.

We powered on the PDP-11/34 and it actually ran! It has a RK611 controller installed and we don't have any RK06 or RK07 drives to go with the controller. We will hunt for a RK06 or RK07 drive, or possibly install an RL211 RL02 disk controller because we have lots of RL02 drives.

We plugged in the TC11/TU56, but there is no output from the power supply. The fuses are OK, so this will take some investigation.

15-FEB-2011

We have learned a little more about this system. The CPU architecture is serial, so it is too slow to support a DECtape. It will support a modified DF32 fixed disk drive, but at 32K words of storage per drive it might not be worth the effort to find and install one. The circuit at the top left of the cabinet has been identified as a modified PT08 teletype interface. This circuit notmally goes in the pedistal of the Teletype. Normally the PT08 only supports 110 baud for teletypes. The modification may allow data rates up to 1200 baud. We need to reverse engineer this circuit to see exactly how it works.

We talked to some experts about the best revival procedure. It sounds like disconnecting the power supply from the CPU chassis, connecting a Variac between the AC and the power supply, and slowly ramping up the AC voltage will "reform" the large filter capacitors without damaging them. Once the AC voltage is brought up to 115V we can test the power supply output to insure that it is within specifications. If the power supply output is OK we can connect it to the CPU chassis and see if it runs. We will have to perform the same capacitor "reform" procedure on the power supplies for the paper tape reader/punch and controller.

17-FEB-2011

Charles Lasner has been providing a lot of technical insite on the design of the PDP-8/S. Apparently it is not capable of running much of the software that runs on other PDP-8 systems. This weekend, we will inventory the paper tapes that came with the system to see what diagnostic programs and software we have, and what will actually run on this system. We have several other PDP-8 systems in the warehouse so even if some of the software will not run on this PDP-8, it may run on the other systems.

19-FEB-2011

Now that we know a little more about this system we did some more investigating. We took pictures of the metals labels on the paper tape reader/punch controller and on the Teletype controller. The Teletype interface cable is connected to the PT08 Teletype controller. We will put a standard DEC current loop connector on the end so we can connect it to any of the DEC terminals that support current loop. We should have access to a Variac next weekend so we can try reforming the capacitors in the power supplies.

26-FEB-2011

Planning... It is likely that this sytem has not been turned on for a very long time. The layers of foil in the large electrolytic filter capacitors in the power supplies may have lost their insulating oxide layer from sitting idle. If we just turned on the power supplies the capacitors would probably short and be permanently damaged. There is a process called reforming, where a limited voltage or current is applied to the capacitor to rebuild the oxide layer. The voltage on the capacitor is slowly increased until the working voltage is reached. At this point it is safe to power up the system. Since the power supplies in this system are of the linear design, we can connect a Variac (variable transformer) between the AC source and the power supply, and disconnect the power supply output from the electronics. The DC output of the power supply will be much lower than normal if the AC input voltage is lower than normal. We will start with a low AC voltage, something like 40VAC. If the capacitors do not get too warm or draw too much current then after sitting at this voltage for an hour or so we can increase the AC voltage. Eventually we will reach 120VAC, the DC output voltage should be normal, and we can connect the power supplies to the electronics.

Execution... We connected a Variac to the 8/S power supply and disconnected the power supply from the electronics.  At low AC voltage, something like 10V there was just a few volts DC output from the power supply. The output stabilized at a voltage and then rose just a few mV. If the output voltage rose for a long time I would be concerned about running the reforming process for a very long time. It looks like the filter capacitors are in good shape. We slowly increased the AC voltage over about 6 hours. When we got to 40VAC the DC output went to about +11.5V and -16.5V. Increasing the AC voltage did not increase the DC output voltage. We connected a homemade circuit that was made from Flip-chips to the power supply to provide a load because we were afraid to just connect it to the CPU. The voltages regulated nicely, but were about 10% high. Probably within the expected range.

We connect the power supply to the 8/S and were rewarded with front panel lights. Some of the toggle switches don't always work so we may need to clean them. It looks like it is substantionally functional. In single step you can see it decode the instructions and light the instruction type lights. I tried toggling in the loopback program that you sent me, but had lots of problems with the switches not going on.

After the system had been powered on for about an hour one of the little capacitors in the power supply started smoking and leaking oil. During some of our reorganizing today I found a brand new, still mounted to the shipping board, still wrapped in plastic power supply for the 8/S. Next weekend we will reform the caps in the new power supply and install it in the 8/S.

5-MAR-2011

Planning... Replace the failed 783A power supply with the new one. Reform the capacitors in the paper tape reader/punch power supply. Clean the switches on the front panel. See if any of the Teletypes in the warehouse work. Try loading the RIM and BIN loaders and then some of the diagnostic programs.

Execution... We replaced the failed power supply with the "brand new" one that we reformed during the week. We started reforming the power supply for the PC01 paper tape reader/punch. The new power supply works great.

Warren Stearns (at the left in the image) stopped by for a visit. Warren showed us lots of pictures of the restoration of Doug Ingraham's PDP-8. Warren also gave us the missing schematics of the 750C/PC01 and 75E and gave us a detailed tutorial on PDP-8 logic and design. Hopefully we can convince Warren to visit again and help with the revival of the PDP-8/L.

12-MAR-2011

Planning... Finish reforming the capacitors in the paper tape reader/punch power supply. Clean the switches on the front panel. See if any of the Teletypes in the warehouse work. Test the CPU behavior with some simple toggle-in programs. Try loading the RIM and BIN loaders and then some of the diagnostic programs. Warren Stearns is planning to visit again. Maybe we can convince him to help with the PDP-8/L.

Execution... We finished reforming the capacitors in the paper tape reader/punch power supply. While the reforming process was running we tried some simple instructions set tests. It looks like the instructions work OK if the computer is running at full speed, but do not work correctly when the computer is single-stepping. The Memory Buffer Address does not display correctly when single-stepping. Warren explained that this is a diode/capacitor/transistor problem on one or more of the Flip-Chip modules. We can still run programs at full-speed, but we will need to fix the single-stepping problem if we need to debug programs.

We toggled in a program that punches the value stored in the accumulator to the paper tape, increments the accumulator, and loops back to the beginning. This loop will send all possible binary values to the paper tape punch. This is a good test of some elements of the processor, the PC01 controller, and the PC03 paper tape punch. This test worked OK. We then toggled in a program that reads the tape that we just punched into the accumulator. This is a good test of some elements of the processor, the Type 750 controller, and the PC02 paper tape reader. This test worked OK too. This means that the system is substantionally functional now.

We found out from the crew at the Goodwill Computer Museum that the 8K version of the core memory really has a capacity of 4K words. DEC could have chosen better model names for the 4K core models than 4K and 8K.

19-MAR-2011

We visited the crew at RCS/RI.

26-MAR-2011

Planning... Change the connector on the end of the Teletype cable to the one that mates with a VT220. Try running some of the diagnostic tapes and see if we can get any output on the console.

Execution... Warren Stearns came to visit again. We spent quite a bit of time organizing the warehouse by putting equipment from the same manufacturer in the same general area. This is always an adventure! We took the metal bezel off the front panel of the PDP-8/S and sprayed contact cleaner into all of the front panel switches. They work MUCH better now. It looked like there was a mix of instructions on core for both the high-speed and low-speed versions of the RIM loader so we toggled in the high-speed version. We used the RIM loader to load the BIN loader. We then used the BIN loader to load in MAINDEC-08-DO4B-D the Random JMP Test. We ran this for about 30 minutes without the system halting, a very good sign. We didn't have a console connected so didn't get to see the diagnostic information displayed.

9-APR-2011

Planning... Put an AMP connector on the end of the console cable and connect it to a VT220 terminal. Rerun the Random JMP test to see if we get console output.

Execution... Warren Stearns came to visit again, but most of our efforts this week were directed towards reorganizing the warehouse. We attempted to connect a VT220 to the PT08 with 20 mA current loop. We couldn't get anything to show up on the console and ran out of debug time.

16-APR-2011

We found another W070 board with a console cable attached. It had the right contacts on the cable end to mate with the VT220, but the wrong plastic housing. We removed the plastic housing and pushed the contacts directly into the 20 mA connector on the back of the VT220. We ran the MAINDEC-08-DO4B-D the Random JMP Test and hoped to get the "04" output periodically showing that it was running OK. No luck, but the program seems to run OK. We toggled in a console loop-back program that Charles Lasner sent us. That let us try the different knob settings on the home-made baud rate board in the PT08 and the serial settings in the VT220. At this point we were not even sure what the connections should be between the PT08 and VT220. With a little experimenting we were able to echo characters typed on the VT220 keyboard back to the VT220 screen. The meant that the console cable connections were correct and the VT220 serial settings were close enough to work with the PT08. Still no output from running the MAINDEC-08-DO4B-D the Random JMP Test again.

Oh well. It is possible that the VT220 serial settings are still not correct. We loaded one of the TTY diags to see if we could get any output on the screen and determine the correct VT220 settings. Nothing. I didn't see the IOT light go on either. Not sure what is happening.

We tried to load the second TTY diag, but the light in the PT01 paper tape reader was out. The bulb was OK, but no voltage to the bulb holder. Another check showed that all of the voltages from the 779 power supply for the reader/punch were just a few millivolts. The AC input is OK. We disconnected the diodes and found that the output from the transformer was just a few millivolts AC. The resistance values for the transformer windings look OK. Maybe the capacitor in the ferroresonant power supplies went bad? At least they didn't fail shorted like they did in the 783A power supply for the CPU.

21-APR-11

The 2 mF 660 VAC run capacitors in the 779 power supply read 1.5 Ohms instead of 2 mF. Bought replacements on eBay. The power supply works great with the replacements installed. I bought two more so I can repair the 783A power supply that was originally in this system.

22-APR-11

Planning...Reinstall the repaired 779 power supply and make sure that the paper tape reader and punch work again. Run the TTY diags to see if we can get some output on the VT220.

Execution...We reinstall the repaired 779 power supply. The paper tape reader/punch is working OK again. With Warren's help were able to toggle in a short program that would send the contents of the switch register out the console serial port. We measured the serial signal and determine what knob settings on the custom made baud rate generator correspond with what baud rate. It is capable of 110/300/1200/2400/9600 baud. After fiddling with the VT220 settings we got the expected sequence of characters displayed on the VT220. We reran the MAINDEC-08-DO4B-D the Random JMP Test. The docs say that it will display an "04" every 72,000 jumps and runs 7,200 jumps per second. We should measure the time between displaying "04" on the console because it is a lot slower than 10 seconds, on the order of two minutes. We tried running one of the TTY diags to see if the display on the VT220 looked reasonable, but it really wants to see a Teletype on the other end.

With our new confidence in the 8/S we reloaded the BIN loader and then loaded FOCAL. It actually loaded and ran. Warren entered a small program to show that it works. It is REALLY slow, but it does run.

30-APR-11

We found that the MPS6534 transistor Q3 on the W707 module in the PT08 Teletype was damaged from the previous week's experiments. Mouser has over 3,000 in stock for a whopping $0.09 each, so we ordered 25 pieces. We should have the W707 repaired for more work next Saturday.

07-MAY-11

The repaired W707 transmitter module for the Teletype interface works fine. Warren Stearns visited again today so we tried running a small Fortran program. The process to run a 4K Fortran program is; toggle in the RIM Loader, use the RIM Loader to load the BIN Loader, use the BIN loader to load the Symbolic Editor, use the Symbolic Editor to create a Fortran program and punch it to paper tape. Then you use the BIN Loader to load the 4K Fortran compiler, use the Fortran compiler to read the source tape and punch the compiled tape. Then you use the BIN loader to load the Fortran Operating System and use the Fortran Operating System to load and run the compiled Fortran program. If it doesn't work GOTO step 1 and start the process over again. Now that the 8/S runs both FOCAL and Fortran we can say that it is mostly functional.

9-JUL-11

We loaded the recently donated Blackjack, Craps, and Chess games on the 8/S All run OK.

 

13-APR-13

We tried to use the PDP-8/S to copy PDP-9 diagnostic paper tapes to the TTY port so we could capture them in binary format on a laptop running a terminal emulator.
Unfortunately the PDP-8/S was reluctant to run, and got progressively worse after a few minutes.
Warren found that the OPR instructions were being incorrectly decoded and some instructions were being treated as HLT instructions.
After a few tries we found that replacing the R001 in slot A35 fixed the problem.
Cleaning the gold fingers on the original R001 also fixed the problem.

The system runs diags OK, but has some problems running FOCAL.
It looks like we will need to remove/clean/replace all of the modules to make this system reliable again.

We were able to make binary images of two PDP-9 diagnostic tapes.
We will make images of the remaining tapes next week.
We will also punch new tapes that we can use.

Comments