Home‎ > ‎Large Systems Collection‎ > ‎

Wang VS65

Wang VS 65 
The VS 65 is part of the CP 7 processor family and can support up to 48 users. The RICM has three VS 65 systems. One was donated by Odell Associates in Charlotte, NC, one was donated by Scarborough Faire in Pawtucket, RI (this one is running), and one was donated by Richard Evans of Cranston, Rhode Island. These are an example of Wang's second generation VS systems. It supports up to 65 terminals and runs Wang's VS (Virtual Storage) operating system.

10/22/11
Dan & Mike surveyed the three systems and attempted to get the most complete system (the one from Scarborough Faire) running. It failed with a CPU error and after we replaced the CPU it failed with a RAM error. Replacing the RAM board with a 2MB version allowed the system to pass power-on diagnostics. The 2-port and the 4-port SMD disk controllers were in the wrong slots so it looked for the boot disk on the external drive controller. We removed the external SMD disk controller and were rewarded with a boot menu. It booted VS from the internal 147 MB 2268V-2 NEC SMD disk drive, but since we don't know any of the userids/passwords we can only run the system as an operator. This system is running VS 7.21.05 and is using a 4230A terminal for the console.
 
10/29/11
Dan/Mike/Warren continued working on the VS systems. We found some notes inside of the Stand Alone Utilities manual that came with this system that included userids and passwords. We were able to login to the system and create our own userids with management authority. We can reinstall the external SMD disk controller and use this system to test the very large collection of SMD disk drives. If we can find the boot drive for the VS 45 we can get that system running too.
 
11/12/11
Mike and Warren set the DIP switches on the 4-port SMD controller for a 75 MB removable disk as drive 0, and 147 MB fixed disks on drives 1-3. We replaced the missing external SMD control cable and connected port 2 to and external 147 MB disk. At this point the system failed CPU/Mem/Cache boot diagnostics. We replaced the memory board and cleaned the over-the-top ribbon cables, but that did not fix the issue. We replaced the CPU and got a different code. We replaced the CPU again and this time it completed diags and booted. We tested three other memory boards and have a good 512K and three good 2 MB boards. We ran Genedit and configured the external drives to match the controller switch settings. After a reboot the external drive was shown as a bootable device. We booted from the internal drive, mounted the external drive, and explored the files. It looked like VS was installed on the drive and it included the required filed for the VS 65, so we tried booting from it. It failed and said that some of the diagnostic files were missing. Fixing that shold be a simple matter of copying the files from the internal drive.
 
11/27/11
Mike and Dan tried five different 2265V-1 75 MB removable drives. Two have power supply problems and show no signs of life. One spins up, but then gets a voltage fault when it tries to move the heads. Two spin up and get seek faults when they try to move the heads. The manuals for this drive are on Bitsavers so there is a chance that we can get a drive working.
 
We also tried adding another 2268V-2 150 MB fixed drive. That didn't work so we replaced the working external drive with another one. That worked OK so we erased the drive and relabled it. We were able to copy files from the internal 150 MB drive to the external 150 MB drive. It is really slow!
 
12/29/11
Mike and Dan connected a 2238V-1 60MB streaming cartridge tape drive to the V65. Unfortunately the rubber coating on the capstan melted from age and gummed up the tape cartridge. We tried a second 2238V-1. This one retensions the tape cartridge, but gets an error when it tries to write to the tape. We have an earlier model tape drive that we will give a try.

10/13/14
We connected a 2266S-3 Archiver to the system so we can get files from a "customers" diskettes. It would not go online, probably because we did not connect the terminal to the Archiver. The terminal looks like a regular workstation, but with different connectors on the back. We will try again with a 2276C-3 Archiver.

10/18/14
We tried configuring the 2276C Archiver and a 2270V3 diskette with Genedit as devices 4 & 5 both on port 4. Unfortunately the Archiver had a power supply problem. We swapped the regulator and heat sink modules from a 2266, but that didn't fix it. We found another 2276C-3 built into a desk. That one had a good power supply. It had all four boards installed, so it probably supports both hard and soft sectored diskettes. We haven't found on of the right terminals yet, but tried connecting it to the 5th set of COAX connectors down on the rear panel of the VS65. Looking at the Workstation status, VS said that the 2276C was Disconnected. I don't know if this is normal or not. We tried a different COAX, but that didn't make a change. We tried to mount a diskette, but that didn't work.



11/25/14
We found what we think is the right model of terminal in our collection to go with the Archiver. It has the connector that matches the one on the Archiver labeled "keyboard". We received a suggestion to make sure that the microcode file for the 2276C was on the VS system. It was not, so that explains a lot of the misbehavior. The microcode for the 2266 Archiver was there. Now we need to look through the hundreds of diskettes in our collection and find the missing microcode file.

11/27/14
We looked through the DEVLIST file as a Wang expert suggested, and verified that the @MC2266C microcode file is used for both the 2266C and the 2276C Archivers. So we do have the right microcode file for both models of Archiver.

Merle dug through a pile of nearly 30 ancient Wang terminals that look identical and found one with a 2266-S part number. This one has the keyboard and video connectors and is the one that works with the Archiver. We cabled it to the 2276C, but saw nothing on the terminal but a dim raster.

We need to verify the switch settings on the boards. The 7545 board has SW1 OFF/ON/ON/ON/OFF/OFF/OFF/OFF and SW2 set to OFF/OFF/OFF/OFF/OFF/ON/ON/ON. This is correct. We will make a better inventory of the board part numbers and switch settings next Saturday when we do some more debugging.

To Do:
Debug the 75 MB removable SMD disk drives to see if we can get one working.
Test the external SMD disk  cables and drive cabinets.
Test more 2268V-2 150 MB fixed drives.
Build a boot drive for the VS 45 when we find the required microcode files.
 
 
 
Comments